Networking

Dell NSeries Switch Basic configuration cheat sheet

In working recently with a few Dell NSeries switches on the bench and in production, I have created a simple cheat sheet for myself with configuration commands I find myself needing most in tweaking and configuring the Dell switches.  I will be added to this post as I find new commands which are helpful.

General Config

show system id – This will show the service tag of the switch

show interfaces status – shows list of all interfaces and their names

interface range tengigabitethernet all – This command in the config interface commandline will select all ten gig ports.

Spanning Tree


Setting spanning tree priority:

  • show spanning-tree detail
  • spanning-tree priority 12288

Enabling PVST

To switch to PVST input the following commands

console>enable

console#config

For rapid-pvst

console(config)# spanning-tree mode rapid-pvst

For legacy devices that use PVST

console(config)#spanning-tree mode pvst

Note: Both PVST modes support up to 8 VLANs. If more than 8 Vlans are configured, the excess VLANs do not participate in per VLAN spanning tree.

To remove specific VLANs from PVST and include specific VLANs, input the following commands. This example removes VLAN 10 and adds VLAN 20.

console(config)#no spanning-tree vlan 10

console(config)#spanning-tree vlan 20


Setting root bridge priority

The following command will set priority for root bridge selection. This example sets vlan 20 and 30 as priority 4096 and VLAN 40 through 45 as priority 8192.

console(config)#spanning-tree vlan 40,50 priority 4096

console(config)#spanning-tree vlan 60-70 priority 8192


Enabling Portfast

STP is recommended to be set in portfast configuration when the ports are an “edge” port (port that goes to an end user device such as a computer, printer, phones, etc. A port in Portfast will move directly to forwarding state when the link comes up without waiting for the forward-time delay.

console(config)#interface te1/0/1

console(config-if)#spanning-tree portfast

To review PVST, run the following command. X is replaced with the VLAN ID you wish to check.

console#show spanning-tree vlan X

VLANS

Voice VLAN:

configure
vlan database
vlan 100
exit
voice vlan
interface range tengigabitethernet all
switchport mode trunk
switchport trunk allowed vlan add 100
voice vlan 100

ClassofService:

classofservice dot1p-mapping 5 5

cos-queue min-bandwidth 0 0 5 5 10 30 40

cos-queue strict 5

To remove VLAN:  issue no in front of the vlans in vlan database command line

Configuring for Trunk Mode:

switchport mode trunk
switchport trunk allowed vlan add 1-4,98-99

remove – switchport trunk allowed vlan remove 5

Configuring for General Mode:

configure
interface gigabitethernet1/1
spanning-tree portfast
switchport mode general
switchport general allowed vlan add 20 tagged
exit
exit

Configuring for Access Mode:

configure
interface gigabitethernet1/1
spanning-tree portfast
switchport access vlan 20
exit
exit
Setting a management IP address

Console (config)# interface vlan 1

Console (config-if)# ip address 10.1.2.3 255.0.0.0

QoS commands
 
show classofservice dot1p-mapping (shows the user priority to traffic class map)
show classofservice ip-dscp-mapping
classofservice ip-dscp-mapping 46 5

 

Subscribe to VirtualizationHowto via Email 🔔

Enter your email address to subscribe to this blog and receive notifications of new posts by email.

Brandon Lee

Brandon Lee is the Senior Writer, Engineer and owner at Virtualizationhowto.com and has over two decades of experience in Information Technology. Having worked for numerous Fortune 500 companies as well as in various industries, Brandon has extensive experience in various IT segments and is a strong advocate for open source technologies. Brandon holds many industry certifications, loves the outdoors and spending time with family.

Related Articles

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.