<?xml version="1.0" encoding="UTF-8"?>        <rss version="2.0"
             xmlns:atom="http://www.w3.org/2005/Atom"
             xmlns:dc="http://purl.org/dc/elements/1.1/"
             xmlns:sy="http://purl.org/rss/1.0/modules/syndication/"
             xmlns:admin="http://webns.net/mvcb/"
             xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
             xmlns:content="http://purl.org/rss/1.0/modules/content/">
        <channel>
            <title>
									phpIPAM Behind Reverse Proxy JQUERY error - Home Lab Forum				            </title>
            <link>https://www.virtualizationhowto.com/community/home-lab-forum/phpipam-behind-reverse-proxy-jquery-error/</link>
            <description>Virtualization Howto Discussion Board</description>
            <language>en-US</language>
            <lastBuildDate>Sun, 13 Sep 2026 08:01:27 +0000</lastBuildDate>
            <generator>wpForo</generator>
            <ttl>60</ttl>
							                    <item>
                        <title>phpIPAM Behind Reverse Proxy JQUERY error</title>
                        <link>https://www.virtualizationhowto.com/community/home-lab-forum/phpipam-behind-reverse-proxy-jquery-error/#post-1026</link>
                        <pubDate>Thu, 03 Oct 2024 02:48:43 +0000</pubDate>
                        <description><![CDATA[One of the cool tools you may run inside your home lab is phpIPAM. The phpIPAM solution is a great little tool that allows you to keep track of your IP addresses not only in your home lab bu...]]></description>
                        <content:encoded><![CDATA[<p>One of the cool tools you may run inside your home lab is phpIPAM. The phpIPAM solution is a great little tool that allows you to keep track of your IP addresses not only in your home lab but even production environments. It is free and open source and you can easily spin it up inside Docker containers. You can read my walkthrough on how to spin it up in Docker here: <a href="https://www.virtualizationhowto.com/2023/04/mastering-phpipam-docker-the-ultimate-setup-guide/">Mastering phpIPAM Docker - The Ultimate Setup Guide.</a></p>
<p>However, if you just try to put phpIPAM behind a reverse proxy like Traefik or Nginx Proxy Manager, you may run into an issue where when you browse to the page, it isn't loading all the stylesheets and is basically just a white page with the text on it.</p>
<p>It will look like the below:</p>
409
<p>If you pull up the browser console, you will see tons of mixed content errors. </p>
411
<p>Why is this error happening when the proxy is supposed to be forwarding all traffic to SSL? Also, in Nginx Proxy Manager, I had the "force SSL" turned on for the proxy host. But, still an error.</p>
<p>As it turns out the resolution is quite simple. It is just an additional parameter in the Docker Compose code for the phpIPAM web container called <strong>IPAM_TRUST_X_FORWARDED=true</strong>.</p>
<pre contenteditable="false">phpipam-web:
    image: phpipam/phpipam-www:latest
    ports:
      - "8100:80"
    environment:
      - TZ=America/Chicago
      - IPAM_DATABASE_HOST=phpipam-mariadb
      - IPAM_DATABASE_PASS=password
      - IPAM_DATABASE_WEBHOST=%
      - IPAM_TRUST_X_FORWARDED=true
    restart: always
    volumes:
      - "/home/linuxadmin/homelabservices/phpipam/phpipam-logo:/phpipam/css/images/logo"
      - "/home/linuxadmin/homelabservices/phpipam/phpipam-ca:/usr/local/share/ca-certificates:ro"
    networks:
      - nginxproxy
    depends_on:
      - phpipam-mariadb
    container_name: phpipam-web
</pre>
<p> </p>
<p>Once I did this I was able to refresh the page (you may need to clear your cache or check in an incognito tab) and phpIPAM loaded normally without JQUERY errors.</p>]]></content:encoded>
						                            <category domain="https://www.virtualizationhowto.com/community/home-lab-forum/">Home Lab Forum</category>                        <dc:creator>Brandon Lee</dc:creator>
                        <guid isPermaLink="true">https://www.virtualizationhowto.com/community/home-lab-forum/phpipam-behind-reverse-proxy-jquery-error/#post-1026</guid>
                    </item>
							        </channel>
        </rss>
		